Fin de soporte a NPAPI en la versión 52 de Firefox (y alternativas)

Una de las novedades que nos encontramos en la nueva versión de Firefox 52, liberada el día 7 de este mes, es que ya no soportará el plugin NPAPI. Si estamos usando nuestras aplicaciones forms a través de Firefox, dejarán de funcionar una vez reciban esta actualización, a menos que las hayamos actualizado a la versión 12c de Forms y estemos usando WebStart.

En el caso de estar en una versión anterior a la 12c, tenemos dos alternativas:

  1. Ejecutar nuestra aplicación a través de Internet Explorer.
  2. Empezar a utilizar la versión Extended Support Release de Firefox, instalándola manualmente.

Podemos encontrar más información sobre ésta versión de Firefox aquí.

Si nos decidimos por esta opción, debemos tener en cuenta que solamente recibiremos las actualizaciones de seguridad y mantenimiento de la versión ESR 52. Por tanto, no recibiremos las novedades de nuevas versiones de Firefox como la versión 53.

En la siguiente imagen vemos cómo se puede activar Java en esta nueva versión:

Aprovechamos para recordar que la versión de Forms 12c tiene dos opciones de implementación en el lado cliente que no dependen del navegador:

  • Java WebStart
    • Soporta SSO (cuando se utiliza con el navegador)
    • No hay soporte para SSO Logout o Integración Java Script
    • Requiere ya sea JDK o plugin de Java (JRE) de instalación
    • Presenta aplicación con un aspecto nativo
  • Standalone
    • No hay soporte para SSO, SSO Logout o Integración Java Script
    • Requiere ya sea JDK o plugin de Java (JRE) de instalación
    • Presenta aplicación con un aspecto nativo
    • Página Ejemplo disponible en: http: // servidor: 9001 / forms / html / fsal.htm
Evolución, innovación y transformación
37 especializaciones avaladas por Oracle
Oportunidades ilimitadas
El equipo marca la diferencia
Posts 100% Oracle
Sigue nuestro día a día